What’s Vulnerable › Vulnerabilities
CVE-2024-45309: OneDev vulnerable to arbitrary file reading for unauthenticated user
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-200
Description
OneDev is a Git server with CI/CD, kanban, and packages. A vulnerability in versions prior to 11.0.9 allows unauthenticated users to read arbitrary files accessible by the OneDev server process. This issue has been fixed in version 11.0.9.
Affected products
- theonedev onedev: before 11.0.9 — fixed in 11.0.9
How to fix
Upgrade to a fixed version: theonedev onedev 11.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/theonedev/onedev/commit/4637aaac8c70d41aa789b7fce208b75c6a7b711f
- https://github.com/theonedev/onedev/security/advisories/GHSA-7wg5-6864-v489
Get alerted when CVE-2024-45309 or the next vulnerability affects your stack