What’s Vulnerable › Vulnerabilities
CVE-2024-45312: Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.
Affected products
- overleaf: from 4.0.0 before 4.2.7; from 5.0.0 before 5.0.7 — fixed in 4.2.7, 5.0.7
How to fix
Upgrade to a fixed version: overleaf 4.2.7, 5.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/overleaf/overleaf/commit/b5e5d39c3ad4e7763d42b837738955f8ded4dcd3
- https://github.com/overleaf/overleaf/security/advisories/GHSA-pxm4-p454-vppg
- https://github.com/overleaf/toolkit
Get alerted when CVE-2024-45312 or the next vulnerability affects your stack