What’s Vulnerable › Vulnerabilities
CVE-2024-45324
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-134
Description
A use of externally-controlled format string vulnerability [CWE-134] in FortiOS version 7.4.0 through 7.4.4, version 7.2.0 through 7.2.9, version 7.0.0 through 7.0.15 and before 6.4.15, FortiProxy version 7.4.0 through 7.4.6, version 7.2.0 through 7.2.12 and before 7.0.19, FortiPAM version 1.4.0 through 1.4.2 and before 1.3.1, FortiSRA version 1.4.0 through 1.4.2 and before 1.3.1 and FortiWeb version 7.4.0 through 7.4.5, version 7.2.0 through 7.2.10 and before 7.0.10 allows a privileged attacker to execute unauthorized code or commands via specially crafted HTTP or HTTPS commands.
Affected products
- Fortinet FortiOS (FortiGate): from 6.2.0 before 6.2.17; from 6.4.0 before 6.4.16; from 7.0.0 before 7.0.16; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.5 — fixed in 6.2.17, 6.4.16, 7.0.16, 7.2.10, 7.4.5
- Fortinet FortiPAM: from 1.0.0 through 1.3.1; from 1.4.0 before 1.4.3 — fixed in 1.4.3
- Fortinet FortiProxy: from 7.0.0 before 7.0.20; from 7.2.0 before 7.2.13; from 7.4.0 before 7.4.7; 7.6.0 — fixed in 7.0.20, 7.2.13, 7.4.7
- Fortinet FortiSRA: from 1.4.0 before 1.4.3 — fixed in 1.4.3
- Fortinet FortiWeb: from 7.0.0 before 7.0.11; from 7.2.0 before 7.2.11; from 7.4.0 before 7.4.6; 7.6.0 — fixed in 7.0.11, 7.2.11, 7.4.6
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.17, 6.4.16, 7.0.16, 7.2.10; Fortinet FortiPAM 1.4.3; Fortinet FortiProxy 7.0.20, 7.2.13, 7.4.7; Fortinet FortiSRA 1.4.3; Fortinet FortiWeb 7.0.11, 7.2.11, 7.4.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45324 or the next vulnerability affects your stack