What’s Vulnerable › Vulnerabilities
CVE-2024-45331
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-16 · updated 2026-07-08
- Weakness: CWE-266
Description
A incorrect privilege assignment vulnerability in Fortinet FortiAnalyzer 7.4.0 through 7.4.3, FortiAnalyzer 7.2.0 through 7.2.5, FortiAnalyzer 7.0 all versions, FortiAnalyzer 6.4 all versions, FortiAnalyzer Cloud 7.4.1 through 7.4.2, FortiAnalyzer Cloud 7.2.1 through 7.2.6, FortiAnalyzer Cloud 7.0 all versions, FortiAnalyzer Cloud 6.4 all versions, FortiManager 7.4.0 through 7.4.3, FortiManager 7.2.0 through 7.2.5, FortiManager 7.0 all versions, FortiManager 6.4 all versions allows attacker to escalate privilege via specific shell commands
Affected products
- Fortinet FortiAnalyzer: from 6.4.0 before 7.2.6; from 7.4.0 before 7.4.4 — fixed in 7.2.6, 7.4.4
- Fortinet FortiAnalyzer Cloud: from 6.4.1 before 7.2.7; from 7.4.1 before 7.4.3 — fixed in 7.2.7, 7.4.3
- Fortinet FortiManager: from 6.4.0 before 7.2.6; from 7.4.0 before 7.4.4 — fixed in 7.2.6, 7.4.4
- Fortinet FortiManager Cloud: from 7.0.1 before 7.2.7; from 7.4.1 before 7.4.4 — fixed in 7.2.7, 7.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiAnalyzer 7.2.6, 7.4.4; Fortinet FortiAnalyzer Cloud 7.2.7, 7.4.3; Fortinet FortiManager 7.2.6, 7.4.4; Fortinet FortiManager Cloud 7.2.7, 7.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45331 or the next vulnerability affects your stack