What’s Vulnerable › Vulnerabilities
CVE-2024-45340: GOAUTH credential leak in cmd/go
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-28 · updated 2026-06-17
Description
Credentials provided via the new GOAUTH feature were not being properly segmented by domain, allowing a malicious server to request credentials they should not have access to. By default, unless otherwise set, this only affected credentials stored in the users .netrc file.
Affected products
- Go: from 1.24.0-0 before 1.24.0-rc.2 — fixed in 1.24.0-rc.2
How to fix
Upgrade to a fixed version: Go 1.24.0-rc.2. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/643097
- https://go.dev/issue/71249
- https://groups.google.com/g/golang-dev/c/CAWXhan3Jww/m/bk9LAa-lCgAJ
- https://pkg.go.dev/vuln/GO-2025-3383
Get alerted when CVE-2024-45340 or the next vulnerability affects your stack