What’s Vulnerable › Vulnerabilities
CVE-2024-45392: SuiteCRM has wrong deletion permission checks on API delete call
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-05 · updated 2026-06-17
- Weakness: CWE-284
Description
SuiteCRM is an open-source customer relationship management (CRM) system. Prior to version 7.14.5 and 8.6.2, insufficient access control checks allow a threat actor to delete records via the API. Versions 7.14.5 and 8.6.2 contain a patch for the issue.
Affected products
- salesagility SuiteCRM: before 7.14.5; from 8.0.0 before 8.6.2 — fixed in 7.14.5, 8.6.2
How to fix
Upgrade to a fixed version: salesagility SuiteCRM 7.14.5, 8.6.2. Check the vendor advisory for mitigations.
References
- https://docs.suitecrm.com/admin/releases/7.14.x/#_7_14_5
- https://github.com/salesagility/SuiteCRM/security/advisories/GHSA-8qfx-h7pm-2587
Get alerted when CVE-2024-45392 or the next vulnerability affects your stack