What’s Vulnerable › Vulnerabilities
CVE-2024-45394: Secret encryption vulnerable to brute-force attacks
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-03 · updated 2026-06-17
- Weakness: CWE-261
Description
Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.
Affected products
- Authenticator-Extension Authenticator: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: Authenticator-Extension Authenticator 8.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/Authenticator-Extension/Authenticator/commit/17aa2068553db3c3aac081c9ffe393536f33b28b
- https://github.com/Authenticator-Extension/Authenticator/security/advisories/GHSA-gv8m-vgp8-q2xr
Get alerted when CVE-2024-45394 or the next vulnerability affects your stack