What’s Vulnerable › Vulnerabilities
CVE-2024-45399: Indico has a Cross-Site-Scripting during account creation
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In Indico prior to version 3.3.4, corresponding to Flask-Multipass prior to version 0.5.5, there is a Cross-Site-Scripting vulnerability during account creation when redirecting to the `next` URL. Exploitation requires initiating the account creation process with a maliciously crafted link, and then finalizing the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users. Indico 3.3.4 upgrades the dependency on Flask-Multipass to version 0.5.5, which fixes the issue. Those who build the Indico package themselves and cannot upgrade can update the `flask-multipass` dependency to `>=0.5.5` which fixes the vulnerability. Otherwise one could configure one's web server to disallow requests containing a query string with a `next` parameter that starts with `javascript:`.
Affected products
- indico: before 3.3.4 — fixed in 3.3.4
How to fix
Upgrade to a fixed version: indico 3.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/indico/flask-multipass/commit/0bdcf656d469e5f675cb56fd644d82fea3a97c2a
- https://github.com/indico/indico/commit/7dcb573837b9fd09d95f74d1baeae225b164cc8f
- https://github.com/indico/indico/releases/tag/v3.3.4
- https://github.com/indico/indico/security/advisories/GHSA-rrqf-w74j-24ff
Get alerted when CVE-2024-45399 or the next vulnerability affects your stack