What’s Vulnerable › Vulnerabilities
CVE-2024-45400: CKEditor Open Link plugin vulnerable to Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
ckeditor-plugin-openlink is a plugin for the CKEditor JavaScript text editor that extends the context menu with a possibility to open a link in a new tab. A vulnerability in versions of the plugin prior to 1.0.7 allowed a user to execute JavaScript code by abusing the link href attribute. The fix is available starting with version 1.0.7.
Affected products
- mlewand ckeditor-plugin-openlink: before 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: mlewand ckeditor-plugin-openlink 1.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/mlewand/ckeditor-plugin-openlink/commit/402391fdd4d9cfd079031372f9caebbf54993ffb
- https://github.com/mlewand/ckeditor-plugin-openlink/security/advisories/GHSA-qj47-6x6q-m3c9
Get alerted when CVE-2024-45400 or the next vulnerability affects your stack