What’s Vulnerable › Vulnerabilities
CVE-2024-45401: stripe-cli Path Traversal vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-05 · updated 2026-06-17
- Weakness: CWE-22
Description
stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.
Affected products
- stripe-cli: from 1.11.1 before 1.21.3 — fixed in 1.21.3
How to fix
Upgrade to a fixed version: stripe-cli 1.21.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45401 or the next vulnerability affects your stack