What’s Vulnerable › Vulnerabilities
CVE-2024-45404: OpenCTI's lack of Rate Limit lead to OTP brute forcing
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-287
Description
OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.
Affected products
- OpenCTI-Platform opencti: before 6.2.18 — fixed in 6.2.18
How to fix
Upgrade to a fixed version: OpenCTI-Platform opencti 6.2.18. Check the vendor advisory for mitigations.
References
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-hg56-r6hh-56j7
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-hg56-r6hh-56j7
Get alerted when CVE-2024-45404 or the next vulnerability affects your stack