What’s Vulnerable › Vulnerabilities

CVE-2024-45409: The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

Description

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.11.10, 17.0.8, 17.1.8, 17.2.7; SAML-Toolkits ruby-saml 1.12.3, 1.17.0; Rubygems Ruby-Saml 1.12.3, 1.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45409 or the next vulnerability affects your stack