What’s Vulnerable › Vulnerabilities
CVE-2024-4543: Snippet Shortcodes <= 4.1.4 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-03 · updated 2026-06-17
- Weakness: CWE-352
Description
The Snippet Shortcodes plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.1.4. This is due to missing or incorrect nonce validation when adding or editing shortcodes. This makes it possible for unauthenticated attackers to modify shortcodes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- aliakro Snippet Shortcodes: before 4.1.5 — fixed in 4.1.5
How to fix
Upgrade to a fixed version: aliakro Snippet Shortcodes 4.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3110951?contextall=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/127b20c4-cd7c-4d04-b32f-bcc26beb2c35?source=cve
- https://plugins.trac.wordpress.org/changeset/3110951?contextall=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/127b20c4-cd7c-4d04-b32f-bcc26beb2c35?source=cve
Get alerted when CVE-2024-4543 or the next vulnerability affects your stack