What’s Vulnerable › Vulnerabilities
CVE-2024-4545: EDB Postgres Advanced Server (EPAS) authenticated file read permissions bypass using edbldr
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-269
Description
All versions of EnterpriseDB Postgres Advanced Server (EPAS) from 15.0 prior to 15.7.0 and from 16.0 prior to 16.3.0 may allow users using edbldr to bypass role permissions from pg_read_server_files. This could allow low privilege users to read files to which they would not otherwise have access.
Affected products
- EnterpriseDB EDB Postgres Advanced Server: from 15.0 before 15.7.0; from 16.0 before 16.3.0 — fixed in 15.7.0, 16.3.0
How to fix
Upgrade to a fixed version: EnterpriseDB EDB Postgres Advanced Server 15.7.0, 16.3.0. Check the vendor advisory for mitigations.
References
- https://www.enterprisedb.com/docs/epas/15/epas_rel_notes/
- https://www.enterprisedb.com/docs/epas/latest/epas_rel_notes/
- https://www.enterprisedb.com/docs/security/advisories/cve20244545/
- https://www.enterprisedb.com/docs/epas/15/epas_rel_notes/
- https://www.enterprisedb.com/docs/epas/latest/epas_rel_notes/
- https://www.enterprisedb.com/docs/security/advisories/cve20244545/
Get alerted when CVE-2024-4545 or the next vulnerability affects your stack