What’s Vulnerable › Vulnerabilities
CVE-2024-45458: WordPress Spiffy Calendar plugin <= 4.9.13 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Spiffy Plugins Spiffy Calendar spiffy-calendar allows Reflected XSS.This issue affects Spiffy Calendar: from n/a through <= 4.9.13.
Affected products
- Spiffy Plugins Spiffy Calendar: before 4.9.14 — fixed in 4.9.14
How to fix
Upgrade to a fixed version: Spiffy Plugins Spiffy Calendar 4.9.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45458 or the next vulnerability affects your stack