What’s Vulnerable › Vulnerabilities
CVE-2024-45479: Apache Ranger: SSRF in Edit Service page - Add logic to filter requests to localhost
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-918
Description
SSRF vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Ranger: from 2.4.0 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 2.5.0. Check the vendor advisory for mitigations.
References
- https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
- http://www.openwall.com/lists/oss-security/2025/01/21/4
Get alerted when CVE-2024-45479 or the next vulnerability affects your stack