What’s Vulnerable › Vulnerabilities
CVE-2024-45505: Apache HertzBeat: Exists Native Deser RCE and file writing vulnerabilities
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-77
Description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache HertzBeat (incubating). This vulnerability can only be exploited by authorized attackers. This issue affects Apache HertzBeat (incubating): before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.
Affected products
- dromara hertzbeat: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: dromara hertzbeat 1.6.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gvbc68krhqhht7mkkkx7k13k6k6fdhy0
- https://lists.apache.org/thread/h8k14o1bfyod66p113pkgnt1s52p6p19
- http://www.openwall.com/lists/oss-security/2024/11/16/4
Get alerted when CVE-2024-45505 or the next vulnerability affects your stack