What’s Vulnerable › Vulnerabilities
CVE-2024-45506
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-835
Description
HAProxy 2.9.x before 2.9.10, 3.0.x before 3.0.4, and 3.1.x through 3.1-dev6 allows a remote denial of service for HTTP/2 zero-copy forwarding (h2_send loop) under a certain set of conditions, as exploited in the wild in 2024.
Affected products
- HAProxy: from 2.9.0 before 2.9.10; from 3.0.0 before 3.0.4; 3.1-dev0, 3.1-dev1, 3.1-dev2, 3.1-dev3, 3.1-dev4, 3.1-dev5 — fixed in 2.9.10, 3.0.4
How to fix
Upgrade to a fixed version: HAProxy 2.9.10, 3.0.4. Check the vendor advisory for mitigations.
References
- http://git.haproxy.org/?p=haproxy-3.0.git%3Ba=commitdiff%3Bh=c725db17e8416ffb3c1537aea756356228ce5e3c
- http://git.haproxy.org/?p=haproxy-3.0.git%3Ba=commitdiff%3Bh=d636e515453320c6e122c313c661a8ac7d387c7f
- https://www.haproxy.org/
- https://www.haproxy.org/download/3.1/src/CHANGELOG
- https://www.mail-archive.com/haproxy%40formilux.org/msg45280.html
- https://www.mail-archive.com/haproxy%40formilux.org/msg45281.html
Get alerted when CVE-2024-45506 or the next vulnerability affects your stack