What’s Vulnerable › Vulnerabilities

CVE-2024-45510

Description

An issue was discovered in Zimbra Collaboration (ZCS) through 10.0. Zimbra Webmail (Modern UI) is vulnerable to a stored Cross-Site Scripting (XSS) attack due to improper sanitization of user input. This allows an attacker to inject malicious code into specific fields of an e-mail message. When the victim adds the attacker to their contacts, the malicious code is stored and executed when viewing the contact list. This can lead to unauthorized actions such as arbitrary mail sending, mailbox exfiltration, profile picture alteration, and other malicious actions. Proper sanitization and escaping of input fields are necessary to mitigate this vulnerability.

Affected products

How to fix

Upgrade to a fixed version: Zimbra Collaboration 10.0.9, 9.0.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45510 or the next vulnerability affects your stack