What’s Vulnerable › Vulnerabilities
CVE-2024-45517
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in Zimbra Collaboration (ZCS) through 10.1. A Cross-Site Scripting (XSS) vulnerability in the /h/rest endpoint of the Zimbra webmail and admin panel interfaces allows attackers to execute arbitrary JavaScript in the victim's session. This issue is caused by improper sanitization of user input, leading to potential compromise of sensitive information. Exploitation requires user interaction to access the malicious URL.
Affected products
- Zimbra Collaboration: before 8.8.15; from 10.0.0 before 10.0.9; 8.8.15, 8.8.15-p1, 8.8.15-p10, 8.8.15-p11, 8.8.15-p12, 8.8.15-p13 (+84) — fixed in 10.0.9, 8.8.15
How to fix
Upgrade to a fixed version: Zimbra Collaboration 10.0.9, 8.8.15. Check the vendor advisory for mitigations.
References
- https://wiki.zimbra.com/wiki/Security_Center
- https://wiki.zimbra.com/wiki/Zimbra_Releases/10.0.9#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/10.1.1#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15/P46#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/9.0.0/P41#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Responsible_Disclosure_Policy
Get alerted when CVE-2024-45517 or the next vulnerability affects your stack