What’s Vulnerable › Vulnerabilities
CVE-2024-45518
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-918
Description
An issue was discovered in Zimbra Collaboration (ZCS) 10.1.x before 10.1.1, 10.0.x before 10.0.9, 9.0.0 before Patch 41, and 8.8.15 before Patch 46. It allows authenticated users to exploit Server-Side Request Forgery (SSRF) due to improper input sanitization and misconfigured domain whitelisting. This issue permits unauthorized HTTP requests to be sent to internal services, which can lead to Remote Code Execution (RCE) by chaining Command Injection within the internal service. When combined with existing XSS vulnerabilities, this SSRF issue can further facilitate Remote Code Execution (RCE).
Affected products
- Zimbra Collaboration: from 10.0.0 before 10.0.9; 8.8.15, 8.8.15-p1, 8.8.15-p10, 8.8.15-p11, 8.8.15-p12, 8.8.15-p13 (+74) — fixed in 10.0.9
How to fix
Upgrade to a fixed version: Zimbra Collaboration 10.0.9. Check the vendor advisory for mitigations.
References
- https://wiki.zimbra.com/wiki/Security_Center
- https://wiki.zimbra.com/wiki/Zimbra_Releases/10.0.9#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/10.1.1#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/8.8.15/P46#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Releases/9.0.0/P41#Security_Fixes
- https://wiki.zimbra.com/wiki/Zimbra_Responsible_Disclosure_Policy
- https://wiki.zimbra.com/wiki/Zimbra_Security_Advisories
Get alerted when CVE-2024-45518 or the next vulnerability affects your stack