What’s Vulnerable › Vulnerabilities
CVE-2024-4557: Uncontrolled Resource Consumption in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-400
Description
Multiple Denial of Service (DoS) conditions has been discovered in GitLab CE/EE affecting all versions starting from 1.0 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1 which allowed an attacker to cause resource exhaustion via banzai pipeline.
Affected products
- GitLab: from 1.0.0 before 16.11.5; from 17.0.0 before 17.0.3; 17.1.0 — fixed in 16.11.5, 17.0.3
How to fix
Upgrade to a fixed version: GitLab 16.11.5, 17.0.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/460517
- https://hackerone.com/reports/2485172
- https://gitlab.com/gitlab-org/gitlab/-/issues/460517
- https://hackerone.com/reports/2485172
Get alerted when CVE-2024-4557 or the next vulnerability affects your stack