What’s Vulnerable › Vulnerabilities
CVE-2024-4558
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-416
Description
Use after free in ANGLE in Google Chrome prior to 124.0.6367.155 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Affected products
- Apple iPadOS: before 17.6 — fixed in 17.6
- Apple Iphone Os: before 17.6 — fixed in 17.6
- Apple macOS: before 14.6 — fixed in 14.6
- Apple Safari: before 17.6 — fixed in 17.6
- Fedoraproject Fedora: 38, 39, 40
- Google Chrome: before 124.0.6367.155 — fixed in 124.0.6367.155
How to fix
Upgrade to a fixed version: Apple iPadOS 17.6; Apple Iphone Os 17.6; Apple macOS 14.6; Apple Safari 17.6; Google Chrome 124.0.6367.155. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2024/Jul/15
- http://seclists.org/fulldisclosure/2024/Jul/16
- http://seclists.org/fulldisclosure/2024/Jul/18
- https://chromereleases.googleblog.com/2024/05/stable-channel-update-for-desktop_7.html
- https://issues.chromium.org/issues/337766133
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6G7EYH2JAK5OJPVNC6AXYQ5K7YGYNCDN/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BWFSZNNWSQYDRYKNLBDGEXXKMBXDYQ3F/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FAWEKDQTHPN7NFEMLIWP7YMIZ2DHF36N/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IPETICRXUOGRIM4U3BCRTIKE3IZWCSBT/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LE3ASLH6QF2E5OVJI5VA3JSEPJFFFMNY/
- http://seclists.org/fulldisclosure/2024/Jul/15
- http://seclists.org/fulldisclosure/2024/Jul/16
Get alerted when CVE-2024-4558 or the next vulnerability affects your stack