What’s Vulnerable › Vulnerabilities
CVE-2024-45590: body-parser vulnerable to denial of service when url encoding is enabled
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-405
Description
body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.
Affected products
- body-parser: before 1.20.3 — fixed in 1.20.3
- Npm Body-Parser: before 1.20.3 — fixed in 1.20.3
How to fix
Upgrade to a fixed version: body-parser 1.20.3; Npm Body-Parser 1.20.3. Check the vendor advisory for mitigations.
References
- https://github.com/expressjs/body-parser/commit/b2695c4450f06ba3b0ccf48d872a229bb41c9bce
- https://github.com/expressjs/body-parser/security/advisories/GHSA-qwcr-r2fm-qrc7
Get alerted when CVE-2024-45590 or the next vulnerability affects your stack