What’s Vulnerable › Vulnerabilities

CVE-2024-45592: auditor-bundle vulnerable to Cross-site Scripting because name of entity does not get escaped

Description

auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.

Affected products

How to fix

Upgrade to a fixed version: DamienHarper auditor-bundle 5.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45592 or the next vulnerability affects your stack