What’s Vulnerable › Vulnerabilities
CVE-2024-45594: Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework. The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.28.3 and 0.29.0.
Affected products
- decidim: from 0.28.0 before 0.28.3 — fixed in 0.28.3
How to fix
Upgrade to a fixed version: decidim 0.28.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45594 or the next vulnerability affects your stack