What’s Vulnerable › Vulnerabilities
CVE-2024-45598: Cacti has a Local File Inclusion (LFI) Vulnerability via Poller Standard Error Log Path
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Cacti is an open source performance and fault management framework. Prior to 1.2.29, an administrator can change the `Poller Standard Error Log Path` parameter in either Installation Step 5 or in Configuration->Settings->Paths tab to a local file inside the server. Then simply going to Logs tab and selecting the name of the local file will show its content on the web UI. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/commit/eca52c6bb3e76c55d66b1040baa6dbf37471a0ae
- https://github.com/Cacti/cacti/security/advisories/GHSA-pv2c-97pp-vxwg
- https://lists.debian.org/debian-lts-announce/2025/02/msg00010.html
Get alerted when CVE-2024-45598 or the next vulnerability affects your stack