What’s Vulnerable › Vulnerabilities
CVE-2024-45604: Directory traversal in the file selector widget in contao/core-bundle
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-22
Description
Contao is an Open Source CMS. In affected versions authenticated users in the back end can list files outside the document root in the file selector widget. Users are advised to update to Contao 4.13.49. There are no known workarounds for this vulnerability.
Affected products
- contao: before 4.13.49 — fixed in 4.13.49
How to fix
Upgrade to a fixed version: contao 4.13.49. Check the vendor advisory for mitigations.
References
- https://contao.org/en/security-advisories/directory-traversal-in-the-fileselector-widget
- https://github.com/contao/contao/security/advisories/GHSA-4p75-5p53-65m9
Get alerted when CVE-2024-45604 or the next vulnerability affects your stack