What’s Vulnerable › Vulnerabilities
CVE-2024-45605: Improper authorization on deletion of user issue alert notifications in sentry
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-639
Description
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.
Affected products
- getsentry sentry: from 23.9.0 before 24.9.0 — fixed in 24.9.0
How to fix
Upgrade to a fixed version: getsentry sentry 24.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted
- https://github.com/getsentry/sentry/pull/77093
- https://github.com/getsentry/sentry/security/advisories/GHSA-54m3-95j9-v89j
Get alerted when CVE-2024-45605 or the next vulnerability affects your stack