What’s Vulnerable › Vulnerabilities
CVE-2024-45607: whatsapp-api-js fails to validate message's signature
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-347
Description
whatsapp-api-js is a TypeScript server agnostic Whatsapp's Official API framework. It's possible to check the payload validation using the WhatsAppAPI.verifyRequestSignature and expect false when the signature is valid. Incorrect Access Control, anyone using the post or verifyRequestSignature methods to handle messages is impacted. This vulnerability is fixed in 4.0.3.
Affected products
- Secreto31126 whatsapp-api-js: from 4.0.0 before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Secreto31126 whatsapp-api-js 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/Secreto31126/whatsapp-api-js/commit/56620c65126427496a94d176082fbd8393a95b6d
- https://github.com/Secreto31126/whatsapp-api-js/pull/371
- https://github.com/Secreto31126/whatsapp-api-js/security/advisories/GHSA-mwhf-vhr5-7j23
Get alerted when CVE-2024-45607 or the next vulnerability affects your stack