What’s Vulnerable › Vulnerabilities
CVE-2024-45613: CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.
Affected products
- ckeditor5: from 40.0.0 before 43.1.1 — fixed in 43.1.1
How to fix
Upgrade to a fixed version: ckeditor5 43.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/ckeditor/ckeditor5/releases/tag/v43.1.1
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-rgg8-g5x8-wr9v
Get alerted when CVE-2024-45613 or the next vulnerability affects your stack