What’s Vulnerable › Vulnerabilities
CVE-2024-45626: Apache James: denial of service through JMAP HTML to text conversion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-06 · updated 2026-06-17
- Weakness: CWE-400
Description
Apache James server JMAP HTML to text plain implementation in versions below 3.8.2 and 3.7.6 is subject to unbounded memory consumption that can result in a denial of service. Users are recommended to upgrade to version 3.7.6 and 3.8.2, which fix this issue.
Affected products
- Apache James Server: before 3.7.6; from 3.8.0 before 3.8.2 — fixed in 3.7.6, 3.8.2
How to fix
Upgrade to a fixed version: Apache James Server 3.7.6, 3.8.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1fr9hvpsylomwwfr3rv82g84sxszn4kl
- http://www.openwall.com/lists/oss-security/2025/02/05/7
Get alerted when CVE-2024-45626 or the next vulnerability affects your stack