What’s Vulnerable › Vulnerabilities
CVE-2024-45627: Apache Linkis Metadata Query Service JDBC: JDBC Datasource Module with Mysql has file read vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-552
Description
In Apache Linkis <1.7.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will allow the attacker to read arbitrary files from the Linkis server. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis < 1.7.0 will be affected. We recommend users upgrade the version of Linkis to version 1.7.0.
Affected products
- Apache Software Foundation Apache Linkis: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Linkis 1.7.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/0zzx8lldwoqgzq98mg61hojgpvn76xsh
- http://www.openwall.com/lists/oss-security/2025/01/14/1
Get alerted when CVE-2024-45627 or the next vulnerability affects your stack