What’s Vulnerable › Vulnerabilities
CVE-2024-45679
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-18 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.3 allows a local attacker to execute arbitrary code by importing a specially crafted file into the product.
Affected products
- Open Asset Import Library Assimp: before 5.4.3 — fixed in 5.4.3
How to fix
Upgrade to a fixed version: Open Asset Import Library Assimp 5.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45679 or the next vulnerability affects your stack