What’s Vulnerable › Vulnerabilities
CVE-2024-45689: Moodle: unprotected access to sensitive information via dynamic tables
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-20 · updated 2026-06-17
- Weakness: CWE-862
Description
A flaw was found in Moodle. Dynamic tables did not enforce capability checks, which resulted in users having the ability to retrieve information they did not have permission to access.
Affected products
- Moodle: before 4.1.13; from 4.2.0 before 4.2.10; from 4.3.0 before 4.3.7; from 4.4.0 before 4.4.3 — fixed in 4.1.13, 4.2.10, 4.3.7, 4.4.3
How to fix
Upgrade to a fixed version: Moodle 4.1.13, 4.2.10, 4.3.7, 4.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45689 or the next vulnerability affects your stack