What’s Vulnerable › Vulnerabilities
CVE-2024-45693: Apache CloudStack: Request origin validation bypass makes account takeover possible
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-352
Description
Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to missing validation of the origin of the requests. This can allow an attacker to gain privileges and access to resources of the authenticated users and may lead to account takeover, disruption, exposure of sensitive data and compromise integrity of the resources owned by the user account that are managed by the platform. This issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3 and 4.19.0.0 through 4.19.1.1 Users are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.15.1.0 before 4.18.2.4; from 4.19.0.0 before 4.19.1.2 — fixed in 4.18.2.4, 4.19.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.18.2.4, 4.19.1.2. Check the vendor advisory for mitigations.
References
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2
- https://lists.apache.org/thread/ktsfjcnj22x4kg49ctock3d9tq7jnvlo
- http://www.openwall.com/lists/oss-security/2024/10/15/5
Get alerted when CVE-2024-45693 or the next vulnerability affects your stack