What’s Vulnerable › Vulnerabilities
CVE-2024-45711: SolarWinds Serv-U FTP Service Directory Traversal Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-22
Description
SolarWinds Serv-U is vulnerable to a directory traversal vulnerability where remote code execution is possible depending on privileges given to the authenticated user. This issue requires a user to be authenticated and this is present when software environment variables are abused. Authentication is required for this vulnerability
Affected products
- SolarWinds Serv-U: before 15.5 — fixed in 15.5
How to fix
Upgrade to a fixed version: SolarWinds Serv-U 15.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45711 or the next vulnerability affects your stack