What’s Vulnerable › Vulnerabilities
CVE-2024-45712: SolarWinds Serv-U Client-Side Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
SolarWinds Serv-U is vulnerable to a client-side cross-site scripting (XSS) vulnerability. The vulnerability can only be performed by an authenticated account, on the local machine, from the local browser session. Therefore the risk is very low.
Affected products
- SolarWinds Serv-U: before 15.5.1 — fixed in 15.5.1
How to fix
Upgrade to a fixed version: SolarWinds Serv-U 15.5.1. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/servu/content/release_notes/servu_15-5-1_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2024-45712
Get alerted when CVE-2024-45712 or the next vulnerability affects your stack