What’s Vulnerable › Vulnerabilities
CVE-2024-45717: SolarWinds Platform Cross- Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The SolarWinds Platform was susceptible to a XSS vulnerability that affects the search and node information section of the user interface. This vulnerability requires authentication and requires user interaction.
Affected products
- SolarWinds Platform: before 2024.4.1 — fixed in 2024.4.1
How to fix
Upgrade to a fixed version: SolarWinds Platform 2024.4.1. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/orionplatform/content/release_notes/solarwinds_platform_2024-4-1_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2024-45717
Get alerted when CVE-2024-45717 or the next vulnerability affects your stack