What’s Vulnerable › Vulnerabilities
CVE-2024-45719: Apache Answer: Predictable Authorization Token Using UUIDv1
- Severity: low (CVSS 2.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-326
Description
Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Answer 1.4.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/sz2d0z39k01nbx3r9pj65t76o1hy9491
- http://www.openwall.com/lists/oss-security/2024/11/22/1
Get alerted when CVE-2024-45719 or the next vulnerability affects your stack