What’s Vulnerable › Vulnerabilities

CVE-2024-45732: Low-privileged user could run search as nobody in SplunkDeploymentServerConfig app

Description

In Splunk Enterprise versions below 9.3.1, and 9.2.0 versions below 9.2.3, and Splunk Cloud Platform versions below 9.2.2403.103, 9.1.2312.200, 9.1.2312.110 and 9.1.2308.208, a low-privileged user that does not hold the "admin" or "power" Splunk roles could run a search as the "nobody" Splunk user in the SplunkDeploymentServerConfig app. This could let the low-privileged user access potentially restricted data.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.3; Splunk Cloud Platform 9.1.2308.208, 9.1.2312.110, 9.2.2403.103. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45732 or the next vulnerability affects your stack