What’s Vulnerable › Vulnerabilities

CVE-2024-45735: Improper Access Control for low-privileged user in Splunk Secure Gateway App

Description

In Splunk Enterprise versions below 9.2.3 and 9.1.6, and Splunk Secure Gateway versions on Splunk Cloud Platform versions below 3.4.259, 3.6.17, and 3.7.0, a low-privileged user that does not hold the "admin" or "power" Splunk roles can see App Key Value Store (KV Store) deployment configuration and public/private keys in the Splunk Secure Gateway App.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.6, 9.2.3; Splunk Cloud Platform 3.4.259, 3.6.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45735 or the next vulnerability affects your stack