What’s Vulnerable › Vulnerabilities

CVE-2024-45740: Persistent Cross-Site Scripting (XSS) through Scheduled Views on Splunk Enterprise

Description

In Splunk Enterprise versions below 9.2.3 and 9.1.6 and Splunk Cloud Platform versions below 9.2.2403, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through Scheduled Views that could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.6, 9.2.3; Splunk Cloud Platform 9.2.2403.100. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45740 or the next vulnerability affects your stack