What’s Vulnerable › Vulnerabilities

CVE-2024-45741: Persistent Cross-Site Scripting (XSS) via props.conf on Splunk Enterprise

Description

In Splunk Enterprise versions below 9.2.3 and 9.1.6 and Splunk Cloud Platform versions below 9.2.2403.108 and 9.1.2312.205, a low-privileged user that does not hold the "admin" or "power" Splunk roles could create a malicious payload through a custom configuration file that the "api.uri" parameter from the "/manager/search/apps/local" endpoint in Splunk Web calls. This could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.6, 9.2.3; Splunk Cloud Platform 9.1.2312.205, 9.2.2403.108. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45741 or the next vulnerability affects your stack