What’s Vulnerable › Vulnerabilities
CVE-2024-45765
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-78
Description
Dell Enterprise SONiC OS, version(s) 4.1.x, 4.2.x, contain(s) an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Command execution. This is a critical severity vulnerability as it allows high privilege OS commands to be executed with a less privileged role; so Dell recommends customers to upgrade at the earliest opportunity.
Affected products
- Dell Enterprise SONiC OS: from 4.1.0 before 4.1.6; from 4.2.0 before 4.2.2 — fixed in 4.1.6, 4.2.2
How to fix
Upgrade to a fixed version: Dell Enterprise SONiC OS 4.1.6, 4.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45765 or the next vulnerability affects your stack