What’s Vulnerable › Vulnerabilities
CVE-2024-45772: Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-30 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator. This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
Affected products
- Apache Software Foundation Apache Lucene Replicator: from 4.4.0 before 9.12.0 — fixed in 9.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Lucene Replicator 9.12.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/3f3oph7bqnqspb9q5p0gm5mgc1b6thjo
- http://www.openwall.com/lists/oss-security/2024/09/29/1
Get alerted when CVE-2024-45772 or the next vulnerability affects your stack