What’s Vulnerable › Vulnerabilities
CVE-2024-45791: Apache HertzBeat: Exposure sensitive token via http GET method with query string
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache HertzBeat. This issue affects Apache HertzBeat: before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.
Affected products
- dromara hertzbeat: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: dromara hertzbeat 1.6.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/jmbsfjsvrfnvosh1ftrm3ry4j3sb7doz
- https://lists.apache.org/thread/lvsczrp8kdynppmzyxtkh4ord4gpw1ph
- http://www.openwall.com/lists/oss-security/2024/11/16/5
Get alerted when CVE-2024-45791 or the next vulnerability affects your stack