What’s Vulnerable › Vulnerabilities
CVE-2024-45793: Cross-site Scripting from in Confidant API call
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Confidant is a open source secret management service that provides user-friendly storage and access to secrets. The following endpoints are subject to a cross site scripting vulnerability: GET /v1/credentials, GET /v1/credentials/, GET /v1/archive/credentials/, GET /v1/archive/credentials, POST /v1/credentials, PUT /v1/credentials/, PUT /v1/credentials//<to_revision>, GET /v1/services, GET /v1/services/, GET /v1/archive/services/, GET /v1/archive/services, PUT /v1/services/, PUT /v1/services//<to_revision>. The attacker needs to be authenticated and have privileges to create new credentials, but could use this to show information and run scripts to other users into the same Confidant instance. This issue has been patched in version 6.6.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- lyft confidant: before 6.6.2
References
- https://github.com/lyft/confidant/security/advisories/GHSA-rxq8-q85f-m866
- https://hackerone.com/reports/2332004
- https://hackerone.com/reports/2456673
- https://hackerone.com/reports/2476542
Get alerted when CVE-2024-45793 or the next vulnerability affects your stack