What’s Vulnerable › Vulnerabilities
CVE-2024-45802: Squid Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to Input Validation, Premature Release of Resource During Expected Lifetime, and Missing Release of Resource after Effective Lifetime bugs, Squid is vulnerable to Denial of Service attacks by a trusted server against all clients using the proxy. This bug is fixed in the default build configuration of Squid version 6.10.
Affected products
- Squid: from 3.0 before 6.10 — fixed in 6.10
How to fix
Upgrade to a fixed version: Squid 6.10. Check the vendor advisory for mitigations.
References
- https://github.com/squid-cache/squid/security/advisories/GHSA-f975-v7qw-q7hj
- https://lists.debian.org/debian-lts-announce/2025/03/msg00009.html
- https://security.netapp.com/advisory/ntap-20250103-0004/
Get alerted when CVE-2024-45802 or the next vulnerability affects your stack