What’s Vulnerable › Vulnerabilities
CVE-2024-45805: OpenCTI leaks support information due to inadequate access control
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-26 · updated 2026-06-17
- Weakness: CWE-200
Description
OpenCTI is an open-source cyber threat intelligence platform. Before 6.3.0, general users can access information that can only be accessed by users with access privileges to admin and support information (SETTINGS_SUPPORT). This is due to inadequate access control for support information (http://<opencti_domain>/storage/get/support/UUID/UUID.zip), and that the UUID is available to general users using an attached query (logs query). This vulnerability is fixed in 6.3.0.
Affected products
- OpenCTI-Platform opencti: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: OpenCTI-Platform opencti 6.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-42mm-c8x3-g5q6
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-42mm-c8x3-g5q6
Get alerted when CVE-2024-45805 or the next vulnerability affects your stack